Search found 6 matches

by jus2poubelle
August 20th, 2013, 6:30 am
Forum: Expression Discussion
Topic: object constructor
Replies: 2
Views: 6563

Re: object constructor

it must be my after effect version. It doesn't work either.

i'll try with another version some day.
Thx for the answer.
by jus2poubelle
August 14th, 2013, 6:32 am
Forum: Expression Discussion
Topic: object constructor
Replies: 2
Views: 6563

object constructor

Hi everybody, I'm having trouble with object constructors inside expressions. AE crashs every time I try to use one. Is there an explanation? just a simple example: function CurveItem( A, B, C, D){ this.A = A; this.B = B; this.C = C; this.D = D; } var theCurve = new CurveItem(a,b c d); (well, I coul...
by jus2poubelle
July 3rd, 2013, 1:19 am
Forum: Scripts Discussion
Topic: blank panel
Replies: 6
Views: 9110

Re: blank panel

OK, I have to do some more tests to be sure. But right now it seems to be the solution.

I can say you've just save my sanity. I was about to cry yesterday. :)

Thank you so much for your help !
by jus2poubelle
July 2nd, 2013, 3:06 am
Forum: Script requests
Topic: Find/Replace Transfer mode
Replies: 1
Views: 5162

Re: Find/Replace Transfer mode

You have to do it for every compItem inside the project, but here is the base code to change blending mode of every layers inside a composition: { var myProj = app.project; var myComp = app.project.activeItem; for (var o = 1; o <= myComp.numLayers; o++) { var myLayer = myComp.layer(o); if ( myLayer....
by jus2poubelle
July 2nd, 2013, 2:36 am
Forum: Scripts Discussion
Topic: blank panel
Replies: 6
Views: 9110

Re: blank panel

ok, I tried to simplify the script and keep only the code around the UI. But the problem doesn't occur anymore... Still, I guess I'm doing it wrong by some manner. So I post it anyhow. If someone can tell me a better way to write my code, i'll be happy function exportToXml(thisObject) { var globalLa...
by jus2poubelle
July 1st, 2013, 7:13 am
Forum: Scripts Discussion
Topic: blank panel
Replies: 6
Views: 9110

blank panel

Hi, I've made a script which works almost like I want it to. But I can't execute it 2 times in the same "session". I have to restart AE each time I want to relaunch the script. If not, the panel appears completely blank. I'm still a novice so I must have done something wrong. But has somebody alread...